Synchronize with trunk revision 59636 (just before Alex's CreateProcess revamp).
[reactos.git] / dll / win32 / netshell / CMakeLists.txt
index ad3b61e..08019a1 100644 (file)
@@ -1,9 +1,16 @@
 
+set_cpp(WITH_RUNTIME)
+
+if(NOT MSVC)
+    # HACK: this should be enabled globally!
+    add_compile_flags_language("-std=c++11" "CXX")
+endif()
+
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
 add_definitions(-D_NETSHELL_)
-set_cpp()
+
 spec2def(netshell.dll netshell.spec)
 
 list(APPEND SOURCE