Synchronize with trunk revision 59636 (just before Alex's CreateProcess revamp).
[reactos.git] / dll / win32 / netshell / CMakeLists.txt
index e001c3c..08019a1 100644 (file)
@@ -1,30 +1,33 @@
 
-add_definitions(-D_NETSHELL_)
+set_cpp(WITH_RUNTIME)
+
+if(NOT MSVC)
+    # HACK: this should be enabled globally!
+    add_compile_flags_language("-std=c++11" "CXX")
+endif()
+
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
+add_definitions(-D_NETSHELL_)
+
 spec2def(netshell.dll netshell.spec)
 
 list(APPEND SOURCE
-    netshell.c
-    shfldr_netconnect.c
-    enumlist.c
+    netshell.cpp
+    shfldr_netconnect.cpp
+    enumlist.cpp
     netshell.rc
-    classfactory.c
-    connectmanager.c
-    lanconnectui.c
-    lanstatusui.c
+    classfactory.cpp
+    connectmanager.cpp
+    lanconnectui.cpp
+    lanstatusui.cpp
+    ${CMAKE_CURRENT_BINARY_DIR}/netshell_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/netshell.def)
 
-add_library(netshell SHARED
-    ${CMAKE_CURRENT_BINARY_DIR}/netshell_precomp.h.gch
-    ${SOURCE})
-
+add_library(netshell SHARED ${SOURCE})
 set_module_type(netshell win32dll)
-
-target_link_libraries(netshell
-    uuid
-    wine)
+target_link_libraries(netshell uuid wine)
 
 add_importlibs(netshell
     msvcrt
@@ -38,8 +41,8 @@ add_importlibs(netshell
     setupapi
     ws2_32
     comctl32
-    kernel32)
-
-add_pch(netshell ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
+    kernel32
+    ntdll)
 
-add_cab_target(netshell 1)
+add_pch(netshell precomp.h)
+add_cd_file(TARGET netshell DESTINATION reactos/system32 FOR all)