[CMAKE]
[reactos.git] / dll / win32 / ntmarta / CMakeLists.txt
index 7647060..6e98937 100644 (file)
@@ -2,22 +2,26 @@
 set_unicode()
 
 add_definitions(-D__WINESRC__)
+
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
-spec2def(ntmarta ${CMAKE_CURRENT_SOURCE_DIR}/ntmarta.spec ${CMAKE_CURRENT_BINARY_DIR}/ntmarta.def)
+spec2def(ntmarta.dll ntmarta.spec)
 
-add_library(ntmarta SHARED ntmarta.c ntmarta.rc)
+list(APPEND SOURCE
+    ntmarta.c
+    ntmarta.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/ntmarta.def)
 
-set_module_type(ntmarta win32dll)
+add_library(ntmarta SHARED ${SOURCE})
 
-target_link_libraries(ntmarta
-    ${CMAKE_CURRENT_BINARY_DIR}/ntmarta.def)
+set_module_type(ntmarta win32dll)
 
 add_importlibs(ntmarta
     user32
     advapi32
+    msvcrt
     kernel32
     ntdll)
 
-add_dependencies(ntmarta ntmarta_def)
+add_cd_file(TARGET ntmarta DESTINATION reactos/system32 FOR all)