[CMAKE]
[reactos.git] / dll / win32 / ntmarta / CMakeLists.txt
index 7647060..c43883d 100644 (file)
@@ -5,19 +5,17 @@ add_definitions(-D__WINESRC__)
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
-spec2def(ntmarta ${CMAKE_CURRENT_SOURCE_DIR}/ntmarta.spec ${CMAKE_CURRENT_BINARY_DIR}/ntmarta.def)
+spec2def(ntmarta.dll ntmarta.spec)
 
 
-add_library(ntmarta SHARED ntmarta.c ntmarta.rc)
+add_library(ntmarta SHARED ntmarta.c ntmarta.rc ${CMAKE_CURRENT_BINARY_DIR}/ntmarta.def)
 
 set_module_type(ntmarta win32dll)
 
 
 set_module_type(ntmarta win32dll)
 
-target_link_libraries(ntmarta
-    ${CMAKE_CURRENT_BINARY_DIR}/ntmarta.def)
-
 add_importlibs(ntmarta
     user32
     advapi32
     kernel32
     ntdll)
 
 add_importlibs(ntmarta
     user32
     advapi32
     kernel32
     ntdll)
 
-add_dependencies(ntmarta ntmarta_def)
+
+add_cab_target(ntmarta 1)