[CMAKE]
[reactos.git] / dll / win32 / objsel / CMakeLists.txt
index ec02f5d..08356b5 100644 (file)
@@ -6,27 +6,27 @@ add_definitions(-D_WIN32_WINNT=0x600)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(objsel ${CMAKE_CURRENT_SOURCE_DIR}/objsel.spec ${CMAKE_CURRENT_BINARY_DIR}/objsel.def)
+spec2def(objsel.dll objsel.spec)
 
-add_library(objsel SHARED
+list(APPEND SOURCE
     factory.c
     objsel.c
     regsvr.c
-    objsel.rc)
+    objsel.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/objsel.def)
+
+add_library(objsel SHARED ${SOURCE})
 
 set_module_type(objsel win32dll)
 
-target_link_libraries(objsel
-    ${CMAKE_CURRENT_BINARY_DIR}/objsel.def
-    uuid
-    wine)
+target_link_libraries(objsel uuid wine)
 
 add_importlibs(objsel
     ole32
     user32
     advapi32
+    msvcrt
     kernel32
     ntdll)
 
-add_dependencies(objsel objsel_def)
-add_cab_target(objsel 1)
+add_cd_file(TARGET objsel DESTINATION reactos/system32)