[CMAKE]
[reactos.git] / dll / win32 / oleacc / CMakeLists.txt
index 59dad21..bf85a9a 100644 (file)
@@ -6,19 +6,18 @@ set_rc_compiler()
 spec2def(oleacc.dll oleacc.spec)
 
 list(APPEND SOURCE
-    main.c oleacc.rc
+    main.c
+    oleacc.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/oleacc_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/oleacc.def)
 
 add_library(oleacc SHARED ${SOURCE})
 
-set_entrypoint(oleacc 0)
+set_module_type(oleacc win32dll)
 
 target_link_libraries(oleacc wine)
 
-add_importlibs(oleacc
-    user32
-    kernel32
-    ntdll)
+add_importlibs(oleacc user32 msvcrt kernel32 ntdll)
 
-
-add_cab_target(oleacc 1)
\ No newline at end of file
+add_importlib_target(oleacc.spec)
+add_cab_target(oleacc 1)