[CMAKE]
[reactos.git] / dll / win32 / oleacc / CMakeLists.txt
index e166528..e9948ef 100644 (file)
@@ -1,21 +1,23 @@
 
 add_definitions(-D__WINESRC__)
-
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
+set_rc_compiler()
 spec2def(oleacc.dll oleacc.spec)
 
-add_library(oleacc SHARED main.c oleacc.rc
+list(APPEND SOURCE
+    main.c
+    oleacc.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/oleacc_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/oleacc.def)
 
-set_entrypoint(oleacc 0)
+add_library(oleacc SHARED ${SOURCE})
 
-target_link_libraries(oleacc wine)
+set_module_type(oleacc win32dll)
 
-add_importlibs(oleacc
-    user32
-    kernel32
-    ntdll)
+target_link_libraries(oleacc wine)
 
+add_importlibs(oleacc user32 msvcrt kernel32 ntdll)
 
-add_cab_target(oleacc 1)
\ No newline at end of file
+add_importlib_target(oleacc.spec)
+add_cd_file(TARGET oleacc DESTINATION reactos/system32 FOR all)