[CMAKE]
[reactos.git] / dll / win32 / olesvr32 / CMakeLists.txt
index 44acdd0..2ec6f56 100644 (file)
@@ -1,19 +1,18 @@
 
-set(CMAKE_C_CREATE_SHARED_LIBRARY "<CMAKE_C_COMPILER> <CMAKE_SHARED_LIBRARY_C_FLAGS> <LINK_FLAGS> <CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS> -o <TARGET> <OBJECTS> <LINK_LIBRARIES> -L${REACTOS_BINARY_DIR}/lib/3rdparty/mingw")
-
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
 add_definitions(-D__WINESRC__)
 
 spec2def(olesvr32 ${CMAKE_CURRENT_SOURCE_DIR}/olesvr32.spec ${CMAKE_CURRENT_BINARY_DIR}/olesvr32.def)
 
 add_library(olesvr32 SHARED olesvr_main.c)
 
-set_target_properties(olesvr32 PROPERTIES LINK_FLAGS "-Wl,-entry,0")
+set_entrypoint(olesvr32 0)
 
 target_link_libraries(olesvr32
     ${CMAKE_CURRENT_BINARY_DIR}/olesvr32.def
     wine
     mingw_common)
 
-add_dependencies(olesvr32 olesvr32_def psdk)
+add_importlibs(olesvr32 kernel32 ntdll)
+add_dependencies(olesvr32 olesvr32_def psdk buildno_header)
+add_cab_target(olesvr32 1)
\ No newline at end of file