[CMAKE]
[reactos.git] / dll / win32 / opengl32 / CMakeLists.txt
index 35a7f7b..bac2bb9 100644 (file)
@@ -3,13 +3,14 @@ set_unicode()
 
 add_definitions(-D_DLL -D__USE_CRTIMP)
 
-spec2def(opengl32 ${CMAKE_CURRENT_SOURCE_DIR}/opengl32.spec ${CMAKE_CURRENT_BINARY_DIR}/opengl32.def)
+spec2def(opengl32.dll opengl32.spec)
 
 list(APPEND SOURCE
     font.c
     gl.c
     opengl32.c
-    wgl.c)
+    wgl.c
+    ${CMAKE_CURRENT_BINARY_DIR}/opengl32.def)
 
 add_library(opengl32 SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/opengl32_opengl32.h.gch
@@ -17,9 +18,6 @@ add_library(opengl32 SHARED
 
 set_module_type(opengl32 win32dll)
 
-target_link_libraries(opengl32
-    ${CMAKE_CURRENT_BINARY_DIR}/opengl32.def)
-
 add_importlibs(opengl32
     msvcrt
     gdi32
@@ -30,5 +28,5 @@ add_importlibs(opengl32
     ntdll)
 
 add_pch(opengl32 ${CMAKE_CURRENT_SOURCE_DIR}/opengl32.h ${SOURCE})
-add_dependencies(opengl32 opengl32_def)
+
 add_cab_target(opengl32 1)