[CMAKE]
[reactos.git] / dll / win32 / pidgen / CMakeLists.txt
index c859525..e175a58 100644 (file)
@@ -8,6 +8,7 @@ spec2def(pidgen.dll pidgen.spec)
 list(APPEND SOURCE
     main.c
     rsrc.rc
 list(APPEND SOURCE
     main.c
     rsrc.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/pidgen_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/pidgen.def)
 
 add_library(pidgen SHARED ${SOURCE})
     ${CMAKE_CURRENT_BINARY_DIR}/pidgen.def)
 
 add_library(pidgen SHARED ${SOURCE})
@@ -18,4 +19,4 @@ target_link_libraries(pidgen wine)
 
 add_importlibs(pidgen msvcrt kernel32 ntdll)
 
 
 add_importlibs(pidgen msvcrt kernel32 ntdll)
 
-add_cab_target(pidgen 1)
+add_cd_file(TARGET pidgen DESTINATION reactos/system32 FOR all)