Git conversion: Make reactos the root directory, move rosapps, rostests, wallpapers...
[reactos.git] / dll / win32 / powrprof / CMakeLists.txt
diff --git a/dll/win32/powrprof/CMakeLists.txt b/dll/win32/powrprof/CMakeLists.txt
new file mode 100644 (file)
index 0000000..44146f9
--- /dev/null
@@ -0,0 +1,12 @@
+
+spec2def(powrprof.dll powrprof.spec ADD_IMPORTLIB)
+
+add_library(powrprof SHARED
+    powrprof.c
+    powrprof.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/powrprof.def)
+
+set_module_type(powrprof win32dll UNICODE)
+target_link_libraries(powrprof wine)
+add_importlibs(powrprof advapi32 user32 comctl32 msvcrt kernel32 ntdll)
+add_cd_file(TARGET powrprof DESTINATION reactos/system32 FOR all)