[CMAKE]
[reactos.git] / dll / win32 / powrprof / CMakeLists.txt
index 1a8cdf3..183a0cb 100644 (file)
@@ -1,15 +1,17 @@
 
-set_unicode()
+spec2def(powrprof.dll powrprof.spec)
 
-spec2def(powrprof ${CMAKE_CURRENT_SOURCE_DIR}/powrprof.spec ${CMAKE_CURRENT_BINARY_DIR}/powrprof.def)
+set_unicode()
 
-add_library(powrprof SHARED powrprof.c powrprof.rc)
+add_library(powrprof SHARED
+    powrprof.c
+    powrprof.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/powrprof.def)
 
 set_module_type(powrprof win32dll)
 
-target_link_libraries(powrprof
-    ${CMAKE_CURRENT_BINARY_DIR}/powrprof.def
-    wine)
+target_link_libraries(powrprof wine)
 
-add_importlibs(powrprof advapi32 user32 comctl32 kernel32 ntdll)
-add_dependencies(powrprof powrprof_def)
+add_importlibs(powrprof advapi32 user32 comctl32 msvcrt kernel32 ntdll)
+add_importlib_target(powrprof.spec)
+add_cd_file(TARGET powrprof DESTINATION reactos/system32 FOR all)