[CMAKE]
[reactos.git] / dll / win32 / psapi / CMakeLists.txt
index c13f086..fe8bbe0 100644 (file)
@@ -1,27 +1,19 @@
 
+spec2def(psapi.dll psapi.spec)
+
 list(APPEND SOURCE
     malloc.c
     psapi.c
     psapi.rc
-    psapi.def)
-
-if(NOT MSVC)
-    set_source_files_properties(psapi.def PROPERTIES EXTERNAL_OBJECT TRUE)
-endif()
+    ${CMAKE_CURRENT_BINARY_DIR}/psapi.def)
 
 add_library(psapi SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/psapi_precomp.h.gch
     ${SOURCE})
 
 set_module_type(psapi win32dll)
-
-target_link_libraries(psapi
-    epsapi
-    ${PSEH_LIB})
-
+target_link_libraries(psapi epsapi ${PSEH_LIB})
 add_importlibs(psapi msvcrt kernel32 ntdll)
 add_importlib_target(psapi.spec)
-
 add_pch(psapi ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
-
 add_cab_target(psapi 1)