[CMAKE]
[reactos.git] / dll / win32 / pstorec / CMakeLists.txt
index 61001f6..88b23c6 100644 (file)
@@ -1,21 +1,22 @@
 
-ADD_TYPELIB(pstorec_tlb pstorec_tlb.idl)
+add_typelib(pstorec_tlb pstorec_tlb.idl)
 add_dependencies(pstorec_tlb stdole2)
 
 add_definitions(-D__WINESRC__)
 
-spec2def(pstorec ${CMAKE_CURRENT_SOURCE_DIR}/pstorec.spec ${CMAKE_CURRENT_BINARY_DIR}/pstorec.def)
+set_rc_compiler()
+spec2def(pstorec.dll pstorec.spec)
 
-add_library(pstorec SHARED pstorec.c rsrc.rc)
+list(APPEND SOURCE
+    pstorec.c
+    rsrc.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/pstorec_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/pstorec.def)
 
-set_module_type(pstorec win32dll)
-
-target_link_libraries(pstorec
-    ${CMAKE_CURRENT_BINARY_DIR}/pstorec.def
-    uuid
-    wine)
+add_library(pstorec SHARED ${SOURCE})
 
+set_module_type(pstorec win32dll)
+target_link_libraries(pstorec uuid wine)
 add_importlibs(pstorec msvcrt kernel32 ntdll)
-
-add_dependencies(pstorec pstorec_tlb pstorec_def)
-add_livecd_target(pstorec reactos/system32)
+add_dependencies(pstorec pstorec_tlb)
+add_cab_target(pstorec 1)