[CMAKE]
[reactos.git] / dll / win32 / qmgr / CMakeLists.txt
index 1db6c3f..e137c9d 100644 (file)
@@ -2,7 +2,9 @@
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-add_idl_interface(qmgr_local.idl)
+set_rc_compiler()
+
+generate_idl_iids(qmgr_local.idl)
 
 spec2def(qmgr.dll qmgr.spec)
 
@@ -21,10 +23,10 @@ list(APPEND SOURCE
 
 add_library(qmgr SHARED ${SOURCE})
 
-add_interface_definitions(qmgr_idlheader qmgr_local.idl)
+add_idl_headers(qmgr_idlheader qmgr_local.idl)
 
 set_module_type(qmgr win32dll)
 target_link_libraries(qmgr uuid wine)
 add_importlibs(qmgr ole32 wininet urlmon advapi32 msvcrt kernel32 ntdll)
-add_cab_target(qmgr 1)
+add_cd_file(TARGET qmgr DESTINATION reactos/system32)
 add_dependencies(qmgr qmgr_idlheader)