[CMAKE]
[reactos.git] / dll / win32 / rasman / CMakeLists.txt
index 436357d..3e9d731 100644 (file)
@@ -1,7 +1,13 @@
-
+set_rc_compiler()
 spec2def(rasman.dll rasman.spec)
 
-add_library(rasman SHARED rasman.c rasman.rc ${CMAKE_CURRENT_BINARY_DIR}/rasman.def)
+list(APPEND SOURCE
+    rasman.c
+    rasman.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/rasman_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/rasman.def)
+
+add_library(rasman SHARED ${SOURCE})
 
 set_module_type(rasman win32dll)
 
@@ -11,4 +17,4 @@ target_link_libraries(rasman
 
 add_importlibs(rasman msvcrt kernel32 ntdll)
 
-add_cab_target(rasman 1)
+add_cd_file(TARGET rasman DESTINATION reactos/system32)