[CMAKE]
[reactos.git] / dll / win32 / resutils / CMakeLists.txt
index 11eabd7..4592d25 100644 (file)
@@ -1,19 +1,20 @@
 
-
-
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
 add_definitions(-D__WINESRC__)
 
-spec2def(resutils ${CMAKE_CURRENT_SOURCE_DIR}/resutils.spec ${CMAKE_CURRENT_BINARY_DIR}/resutils.def)
+spec2def(resutils.dll resutils.spec)
+
+list(APPEND SOURCE
+    resutils.c
+    ${CMAKE_CURRENT_BINARY_DIR}/resutils_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/resutils.def)
+
+add_library(resutils SHARED ${SOURCE})
 
-add_library(resutils SHARED resutils.c)
+set_module_type(resutils win32dll)
 
-set_target_properties(resutils PROPERTIES LINK_FLAGS "-Wl,-entry,_DllMain@12")
+target_link_libraries(resutils wine)
 
-target_link_libraries(resutils
-    ${CMAKE_CURRENT_BINARY_DIR}/resutils.def
-    wine
-    mingw_common)
+add_importlibs(resutils msvcrt kernel32 ntdll)
 
-add_dependencies(resutils resutils_def psdk)
+add_cd_file(TARGET resutils DESTINATION reactos/system32 FOR all)