[CMAKE]
[reactos.git] / dll / win32 / rsabase / CMakeLists.txt
index 9483bb4..d9060f0 100644 (file)
@@ -2,16 +2,15 @@
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-add_library(rsabase SHARED version.rc rsabase.def)
+spec2def(rsabase.dll rsabase.spec)
 
-if(NOT MSVC)
-    set_source_files_properties(rsabase.def PROPERTIES EXTERNAL_OBJECT TRUE)
-endif()
+list(APPEND SOURCE
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/rsabase.def)
 
-set_entrypoint(rsabase 0)
+add_library(rsabase SHARED ${SOURCE})
 
+set_entrypoint(rsabase 0)
 target_link_libraries(rsabase wine)
-
 add_importlibs(rsabase rsaenh ntdll)
-
-add_cab_target(rsabase 1)
\ No newline at end of file
+add_cd_file(TARGET rsabase DESTINATION reactos/system32 FOR all)