[CMAKE]
[reactos.git] / dll / win32 / rsaenh / CMakeLists.txt
index d5ae0ae..2036e17 100644 (file)
@@ -1,12 +1,13 @@
 
-add_definitions(-D__WINESRC__)
-add_definitions(-D_DLL -D__USE_CRTIMP)
+add_definitions(
+    -D__WINESRC__
+    -D_DLL -D__USE_CRTIMP)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(rsaenh ${CMAKE_CURRENT_SOURCE_DIR}/rsaenh.spec ${CMAKE_CURRENT_BINARY_DIR}/rsaenh.def)
+spec2def(rsaenh.dll rsaenh.spec)
 
-add_library(rsaenh SHARED
+list(APPEND SOURCE
     aes.c
     des.c
     handle.c
@@ -18,15 +19,13 @@ add_library(rsaenh SHARED
     rsa.c
     rsaenh.c
     sha2.c
-    version.rc)
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/rsaenh.def)
 
-set_module_type(rsaenh win32dll)
-
-target_link_libraries(rsaenh
-    ${CMAKE_CURRENT_BINARY_DIR}/rsaenh.def
-    wine)
+add_library(rsaenh SHARED ${SOURCE})
 
+set_module_type(rsaenh win32dll)
+target_link_libraries(rsaenh wine)
 add_importlibs(rsaenh msvcrt crypt32 advapi32 kernel32 ntdll)
-
-add_dependencies(rsaenh rsaenh_def)
-add_livecd_target(rsaenh reactos/system32)
+add_importlib_target(rsaenh.spec)
+add_cd_file(TARGET rsaenh DESTINATION reactos/system32)