* Sync up to trunk head (r64921).
[reactos.git] / dll / win32 / rsaenh / CMakeLists.txt
index 1fea4c9..7e73f52 100644 (file)
@@ -1,8 +1,7 @@
 
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
-spec2def(rsaenh.dll rsaenh.spec)
+spec2def(rsaenh.dll rsaenh.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
     aes.c
@@ -16,14 +15,15 @@ list(APPEND SOURCE
     rsa.c
     rsaenh.c
     sha2.c
-    version.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/rsaenh.def)
+    tomcrypt.h)
 
-add_library(rsaenh SHARED ${SOURCE})
+add_library(rsaenh SHARED
+    ${SOURCE}
+    rsrc.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/rsaenh.def)
 
 set_module_type(rsaenh win32dll)
 target_link_libraries(rsaenh wine)
 add_importlibs(rsaenh msvcrt crypt32 advapi32 kernel32 ntdll)
-add_pch(rsaenh tomcrypt.h)
-add_importlib_target(rsaenh.spec)
+add_pch(rsaenh tomcrypt.h SOURCE)
 add_cd_file(TARGET rsaenh DESTINATION reactos/system32 FOR all)