* Sync up to trunk head (r64921).
[reactos.git] / dll / win32 / rsaenh / CMakeLists.txt
index 437e737..7e73f52 100644 (file)
@@ -1,7 +1,6 @@
 
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
 spec2def(rsaenh.dll rsaenh.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
@@ -16,12 +15,15 @@ list(APPEND SOURCE
     rsa.c
     rsaenh.c
     sha2.c
+    tomcrypt.h)
+
+add_library(rsaenh SHARED
+    ${SOURCE}
     rsrc.rc
     ${CMAKE_CURRENT_BINARY_DIR}/rsaenh.def)
 
-add_library(rsaenh SHARED ${SOURCE})
 set_module_type(rsaenh win32dll)
-target_link_libraries(rsaenh uuid wine)
+target_link_libraries(rsaenh wine)
 add_importlibs(rsaenh msvcrt crypt32 advapi32 kernel32 ntdll)
-add_pch(rsaenh tomcrypt.h)
+add_pch(rsaenh tomcrypt.h SOURCE)
 add_cd_file(TARGET rsaenh DESTINATION reactos/system32 FOR all)