* Sync up to trunk head (r64921).
[reactos.git] / dll / win32 / rsaenh / CMakeLists.txt
index ac8985b..7e73f52 100644 (file)
@@ -15,11 +15,15 @@ list(APPEND SOURCE
     rsa.c
     rsaenh.c
     sha2.c
+    tomcrypt.h)
+
+add_library(rsaenh SHARED
+    ${SOURCE}
+    rsrc.rc
     ${CMAKE_CURRENT_BINARY_DIR}/rsaenh.def)
 
-add_library(rsaenh SHARED ${SOURCE} rsrc.rc)
 set_module_type(rsaenh win32dll)
 target_link_libraries(rsaenh wine)
 add_importlibs(rsaenh msvcrt crypt32 advapi32 kernel32 ntdll)
-add_pch(rsaenh tomcrypt.h)
+add_pch(rsaenh tomcrypt.h SOURCE)
 add_cd_file(TARGET rsaenh DESTINATION reactos/system32 FOR all)