* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / dll / win32 / samlib / CMakeLists.txt
index ea6c9c0..3a9ff38 100644 (file)
@@ -10,14 +10,17 @@ add_rpc_files(client ${REACTOS_SOURCE_DIR}/include/reactos/idl/sam.idl)
 list(APPEND SOURCE
     dllmain.c
     samlib.c
+    precomp.h
+    ${CMAKE_CURRENT_BINARY_DIR}/sam_c.c
+    ${CMAKE_CURRENT_BINARY_DIR}/samlib_stubs.c)
+
+add_library(samlib SHARED
+    ${SOURCE}
     samlib.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/samlib_stubs.c
-    ${CMAKE_CURRENT_BINARY_DIR}/samlib.def
-    ${CMAKE_CURRENT_BINARY_DIR}/sam_c.c)
+    ${CMAKE_CURRENT_BINARY_DIR}/samlib.def)
 
-add_library(samlib SHARED ${SOURCE})
 set_module_type(samlib win32dll UNICODE)
 target_link_libraries(samlib wine ${PSEH_LIB})
 add_importlibs(samlib rpcrt4 advapi32 msvcrt kernel32 ntdll)
-add_pch(samlib precomp.h)
+add_pch(samlib precomp.h SOURCE)
 add_cd_file(TARGET samlib DESTINATION reactos/system32 FOR all)