[NTOS:KE/x64] Handle NMI vs swapgs race condition
[reactos.git] / dll / win32 / samlib / CMakeLists.txt
index 9af1c0c..7cf73e2 100644 (file)
@@ -1,28 +1,26 @@
 
 include_directories(
-    ${REACTOS_SOURCE_DIR}/include/reactos/idl
-    ${REACTOS_SOURCE_DIR}/include/reactos/wine)
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/idl
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 
 add_definitions(-D__WINESRC__)
-
-set_rc_compiler()
 spec2def(samlib.dll samlib.spec ADD_IMPORTLIB)
-
-add_rpc_files(client
-    ${REACTOS_SOURCE_DIR}/include/reactos/idl/sam.idl)
+add_rpc_files(client ${REACTOS_SOURCE_DIR}/sdk/include/reactos/idl/sam.idl)
 
 list(APPEND SOURCE
     dllmain.c
     samlib.c
+    precomp.h
+    ${CMAKE_CURRENT_BINARY_DIR}/sam_c.c
+    ${CMAKE_CURRENT_BINARY_DIR}/samlib_stubs.c)
+
+add_library(samlib MODULE
+    ${SOURCE}
     samlib.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/samlib_stubs.c
-    ${CMAKE_CURRENT_BINARY_DIR}/samlib.def
-    ${CMAKE_CURRENT_BINARY_DIR}/sam_c.c)
+    ${CMAKE_CURRENT_BINARY_DIR}/samlib.def)
 
-add_library(samlib SHARED ${SOURCE})
 set_module_type(samlib win32dll UNICODE)
 target_link_libraries(samlib wine ${PSEH_LIB})
 add_importlibs(samlib rpcrt4 advapi32 msvcrt kernel32 ntdll)
-add_pch(samlib precomp.h)
+add_pch(samlib precomp.h SOURCE)
 add_cd_file(TARGET samlib DESTINATION reactos/system32 FOR all)
-