[CMAKE]
[reactos.git] / dll / win32 / samlib / CMakeLists.txt
index 533c360..ea648fa 100644 (file)
@@ -2,12 +2,21 @@
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 add_definitions(-D__WINESRC__)
 
+set_rc_compiler()
 spec2def(samlib.dll samlib.spec)
 
-add_library(samlib SHARED dllmain.c samlib.c samlib.rc ${CMAKE_CURRENT_BINARY_DIR}/samlib.def)
+list(APPEND SOURCE
+    dllmain.c
+    samlib.c
+    samlib.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/samlib_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/samlib.def)
+
+add_library(samlib SHARED ${SOURCE})
 
 set_module_type(samlib win32dll)
 
-add_importlibs(samlib advapi32 kernel32 ntdll)
+add_importlibs(samlib advapi32 msvcrt kernel32 ntdll)
 
 add_cab_target(samlib 1)
+add_importlib_target(samlib.spec)