[CMAKE]
[reactos.git] / dll / win32 / sccbase / CMakeLists.txt
index 08905ef..45f0a05 100644 (file)
@@ -2,16 +2,19 @@
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 add_definitions(-D__WINESRC__)
 
-spec2def(sccbase ${CMAKE_CURRENT_SOURCE_DIR}/sccbase.spec ${CMAKE_CURRENT_BINARY_DIR}/sccbase.def)
+spec2def(sccbase.dll sccbase.spec)
 
-add_library(sccbase SHARED main.c)
+list(APPEND SOURCE
+    main.c
+    ${CMAKE_CURRENT_BINARY_DIR}/sccbase_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/sccbase.def)
+
+add_library(sccbase SHARED ${SOURCE})
 
 set_module_type(sccbase win32dll)
 
-target_link_libraries(sccbase
-    ${CMAKE_CURRENT_BINARY_DIR}/sccbase.def
-    wine)
+target_link_libraries(sccbase wine)
+
+add_importlibs(sccbase msvcrt kernel32 ntdll)
 
-add_importlibs(sccbase kernel32 ntdll)
-add_dependencies(sccbase sccbase_def)
-add_livecd_target(sccbase reactos/system32)
+add_cd_file(TARGET sccbase DESTINATION reactos/system32 FOR all)