[CMAKE]
[reactos.git] / dll / win32 / sccbase / CMakeLists.txt
index 5280ae1..45f0a05 100644 (file)
@@ -4,7 +4,12 @@ add_definitions(-D__WINESRC__)
 
 spec2def(sccbase.dll sccbase.spec)
 
-add_library(sccbase SHARED main.c ${CMAKE_CURRENT_BINARY_DIR}/sccbase.def)
+list(APPEND SOURCE
+    main.c
+    ${CMAKE_CURRENT_BINARY_DIR}/sccbase_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/sccbase.def)
+
+add_library(sccbase SHARED ${SOURCE})
 
 set_module_type(sccbase win32dll)
 
@@ -12,4 +17,4 @@ target_link_libraries(sccbase wine)
 
 add_importlibs(sccbase msvcrt kernel32 ntdll)
 
-add_cab_target(sccbase 1)
+add_cd_file(TARGET sccbase DESTINATION reactos/system32 FOR all)