[CMAKE]
[reactos.git] / dll / win32 / schannel / CMakeLists.txt
index 37968b9..3301adb 100644 (file)
@@ -1,20 +1,23 @@
-
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 add_definitions(-D__WINESRC__)
 
+set_rc_compiler()
 spec2def(schannel.dll schannel.spec)
 
-add_library(schannel SHARED
+list(APPEND SOURCE
     lsamode.c
     schannel_main.c
     usermode.c
     version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/schannel_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/schannel.def)
 
+add_library(schannel SHARED ${SOURCE})
+
 set_module_type(schannel win32dll)
 
 target_link_libraries(schannel wine)
 
-add_importlibs(schannel secur32 kernel32 ntdll)
+add_importlibs(schannel secur32 msvcrt kernel32 ntdll)
 
 add_cab_target(schannel 1)