[CMAKE]
[reactos.git] / dll / win32 / schannel / CMakeLists.txt
index 01bd094..de83c95 100644 (file)
@@ -1,21 +1,23 @@
-
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 add_definitions(-D__WINESRC__)
 
-spec2def(schannel ${CMAKE_CURRENT_SOURCE_DIR}/schannel.spec ${CMAKE_CURRENT_BINARY_DIR}/schannel.def)
+set_rc_compiler()
+spec2def(schannel.dll schannel.spec)
 
-add_library(schannel SHARED
+list(APPEND SOURCE
     lsamode.c
     schannel_main.c
     usermode.c
-    version.rc)
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/schannel_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/schannel.def)
+
+add_library(schannel SHARED ${SOURCE})
 
 set_module_type(schannel win32dll)
 
-target_link_libraries(schannel
-    ${CMAKE_CURRENT_BINARY_DIR}/schannel.def
-    wine)
+target_link_libraries(schannel wine)
+
+add_importlibs(schannel secur32 msvcrt kernel32 ntdll)
 
-add_importlibs(schannel secur32 kernel32 ntdll)
-add_dependencies(schannel schannel_def)
-add_livecd_target(schannel reactos/system32)
+add_cd_file(TARGET schannel DESTINATION reactos/system32 FOR all)