[CMAKE]
[reactos.git] / dll / win32 / security / CMakeLists.txt
index bf0f923..c4fc43b 100644 (file)
@@ -1,15 +1,16 @@
-
 set_unicode()
-
 add_definitions(-D__SECURITY__)
 
+set_rc_compiler()
 spec2def(security.dll security.spec)
 
-add_library(security SHARED security.rc
+list(APPEND SOURCE
+    security.rc
     ${CMAKE_CURRENT_BINARY_DIR}/security.def)
 
+add_library(security SHARED ${SOURCE})
 set_entrypoint(security 0)
 
-add_importlibs(security advapi32 ntdll)
+add_importlibs(security secur32 advapi32 ntdll kernel32)
 
-add_cab_target(security 1)
\ No newline at end of file
+add_cd_file(TARGET security DESTINATION reactos/system32)