[CMAKE]
[reactos.git] / dll / win32 / sfc / CMakeLists.txt
index c4ca650..26c0dbc 100644 (file)
@@ -1,7 +1,9 @@
 
-spec2def(sfc ${CMAKE_CURRENT_SOURCE_DIR}/sfc.spec ${CMAKE_CURRENT_BINARY_DIR}/sfc.def)
+spec2def(sfc.dll sfc.spec)
 
-list(APPEND SOURCE sfc.c)
+list(APPEND SOURCE
+    sfc.c
+    ${CMAKE_CURRENT_BINARY_DIR}/sfc.def)
 
 add_library(sfc SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/sfc_precomp.h.gch
@@ -9,9 +11,9 @@ add_library(sfc SHARED
 
 set_module_type(sfc win32dll)
 
-target_link_libraries(sfc ${CMAKE_CURRENT_BINARY_DIR}/sfc.def)
+
 
 add_importlibs(sfc kernel32)
 add_pch(sfc ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
-add_dependencies(sfc sfc_def)
-add_livecd_target(sfc reactos/system32)
+
+add_cab_target(sfc 1)