[CMAKE]
[reactos.git] / dll / win32 / sfc_os / CMakeLists.txt
index b563641..1f38a28 100644 (file)
@@ -3,6 +3,7 @@ spec2def(sfc_os.dll sfc_os.spec)
 
 list(APPEND SOURCE
     sfc_os.c
+    ${CMAKE_CURRENT_BINARY_DIR}/sfc_os_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/sfc_os.def)
 
 add_library(sfc_os SHARED
@@ -11,7 +12,7 @@ add_library(sfc_os SHARED
 
 set_module_type(sfc_os win32dll)
 
-add_importlibs(sfc_os kernel32 ntdll)
+add_importlibs(sfc_os msvcrt kernel32 ntdll)
 add_pch(sfc_os ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
 
-add_cab_target(sfc_os 1)
+add_cd_file(TARGET sfc_os DESTINATION reactos/system32)