[CMAKE] Use modules instead of shared libraries
[reactos.git] / dll / win32 / sfc_os / CMakeLists.txt
index d9713f9..4d722e9 100644 (file)
@@ -6,7 +6,7 @@ list(APPEND SOURCE
     ${CMAKE_CURRENT_BINARY_DIR}/sfc_os_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/sfc_os.def)
 
-add_library(sfc_os SHARED ${SOURCE})
+add_library(sfc_os MODULE ${SOURCE})
 set_module_type(sfc_os win32dll)
 add_importlibs(sfc_os msvcrt kernel32 ntdll)
 add_cd_file(TARGET sfc_os DESTINATION reactos/system32 FOR all)