[CMAKE]
[reactos.git] / dll / win32 / shell32 / CMakeLists.txt
index 69262a2..1a4e2b4 100644 (file)
@@ -1,4 +1,19 @@
 
+remove_definitions(-D_WIN32_WINNT=0x502)
+add_definitions(-D_WIN32_WINNT=0x600)
+
+add_definitions(
+    -D_SHELL32_
+    -DCOM_NO_WINDOWS_H
+    -D_WINE)
+
+include_directories(
+    ${REACTOS_SOURCE_DIR}/include/reactos/wine
+    ${REACTOS_SOURCE_DIR}/lib/recyclebin
+    ${REACTOS_SOURCE_DIR})
+
+add_idl_interface(shobjidl_local.idl)
+
 spec2def(shell32.dll shell32.spec)
 
 list(APPEND SOURCE
@@ -56,21 +71,9 @@ list(APPEND SOURCE
     shv_item_new.c
     folder_options.c
     shell32.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/shobjidl_local_i.c
     ${CMAKE_CURRENT_BINARY_DIR}/shell32.def)
 
-remove_definitions(-D_WIN32_WINNT=0x502)
-add_definitions(-D_WIN32_WINNT=0x600)
-
-add_definitions(
-    -D_SHELL32_
-    -DCOM_NO_WINDOWS_H
-    -D_WINE)
-
-include_directories(
-    ${REACTOS_SOURCE_DIR}/include/reactos/wine
-    ${REACTOS_SOURCE_DIR}/lib/recyclebin
-    ${REACTOS_SOURCE_DIR})
-
 add_pch(shell32 ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
 
 add_library(shell32 SHARED ${CMAKE_CURRENT_BINARY_DIR}/shell32_precomp.h.gch ${SOURCE})