[SHELL32]
[reactos.git] / dll / win32 / shell32 / CMakeLists.txt
index 3800d52..8a2814e 100644 (file)
@@ -1,40 +1,47 @@
-set_cpp()
+PROJECT(SHELL)
+
+set_cpp(WITH_RUNTIME)
+spec2def(shell32.dll shell32.spec ADD_IMPORTLIB)
 
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
 add_definitions(
     -D_SHELL32_
-    -DCOM_NO_WINDOWS_H
     -D_WINE)
 
 include_directories(
-    ${REACTOS_SOURCE_DIR}/include/reactos/wine
     ${REACTOS_SOURCE_DIR}/lib/recyclebin
     ${REACTOS_SOURCE_DIR}/lib/atl
     ${REACTOS_SOURCE_DIR})
 
-spec2def(shell32.dll shell32.spec ADD_IMPORTLIB)
-
 list(APPEND SOURCE
-    authors.cpp
+    #authors.cpp
     autocomplete.cpp
     brsfolder.cpp
     changenotify.cpp
     classes.cpp
     clipboard.cpp
     control.cpp
+    CMenuBand.cpp
+    CMenuDeskBar.cpp
     dataobject.cpp
     dde.cpp
     debughlp.cpp
     desktop.cpp
-    dialogs.cpp
+    dialogs/dialogs.cpp
+    dialogs/drive.cpp
+    dialogs/drvdefext.cpp
+    dialogs/folder_options.cpp
+    dialogs/filedefext.cpp
+    dialogs/fprop.cpp
     dragdrophelper.cpp
     enumidlist.cpp
     extracticon.cpp
     folders.cpp
     iconcache.cpp
     pidl.cpp
+    shell32.cpp
     shell32_main.cpp
     shellitem.cpp
     shelllink.cpp
@@ -42,7 +49,6 @@ list(APPEND SOURCE
     shellord.cpp
     shellpath.cpp
     shellreg.cpp
-    shellstring.cpp
     folders/desktop.cpp
     folders/fs.cpp
     folders/mycomp.cpp
@@ -53,6 +59,7 @@ list(APPEND SOURCE
     folders/fonts.cpp
     folders/cpanel.cpp
     folders/recyclebin.cpp
+    droptargets/CexeDropHandler.cpp
     shlexec.cpp
     shlfileop.cpp
     shlfolder.cpp
@@ -62,53 +69,23 @@ list(APPEND SOURCE
     shpolicy.cpp
     stubs.cpp
     systray.cpp
-    fprop.cpp
-    drive.cpp
     defcontextmenu.cpp
     openwithmenu.cpp
     newmenu.cpp
     startmenu.cpp
-    folder_options.cpp
-    filedefext.cpp
-    drvdefext.cpp
-    ${CMAKE_CURRENT_BINARY_DIR}/shell32_stubs.c
-    ${CMAKE_CURRENT_BINARY_DIR}/shell32.def)
+    precomp.h)
 
 add_library(shell32 SHARED
     ${SOURCE}
-    shell32.rc)
-
-if(NOT MSVC)
-    # FIXME: http://www.cmake.org/Bug/view.php?id=12998
-    #allow_warnings(shell32)
-    set_source_files_properties(${SOURCE} PROPERTIES COMPILE_FLAGS "-Wno-error")
-endif()
-
-set_module_type(shell32 win32dll UNICODE)
-
-target_link_libraries(shell32
-    atlnew
-    wine
-    uuid
-    recyclebin)
+    wine/shellstring.c
+    vista.c
+    shell32.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/shell32_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/shell32.def)
 
+set_module_type(shell32 win32dll UNICODE HOTPATCHABLE)
+target_link_libraries(shell32 atlnew wine uuid recyclebin)
 add_delay_importlibs(shell32 ole32 version fmifs)
-
-add_importlibs(shell32
-    advapi32
-    gdi32
-    user32
-    comctl32
-    comdlg32
-    shdocvw
-    shlwapi
-    devmgr
-    winspool
-    winmm
-    msvcrt
-    kernel32
-    ntdll)
-
-add_dependencies(shdocvw shdocvw_v1)
-add_pch(shell32 precomp.h)
+add_importlibs(shell32 advapi32 browseui gdi32 user32 powrprof comctl32 comdlg32 shdocvw shlwapi devmgr winspool winmm msvcrt kernel32 ntdll)
+add_pch(shell32 precomp.h SOURCE)
 add_cd_file(TARGET shell32 DESTINATION reactos/system32 FOR all)