[SHELL32]
[reactos.git] / dll / win32 / shell32 / CMakeLists.txt
index 47f9575..c34883d 100644 (file)
@@ -22,28 +22,27 @@ list(APPEND SOURCE
     changenotify.cpp
     classes.cpp
     clipboard.cpp
-    control.cpp
     CMenuBand.cpp
     CMenuDeskBar.cpp
     dataobject.cpp
     dde.cpp
     debughlp.cpp
     desktop.cpp
-    dialogs.cpp
+    dialogs/dialogs.cpp
+    dialogs/drive.cpp
+    dialogs/drvdefext.cpp
+    dialogs/folder_options.cpp
+    dialogs/filedefext.cpp
+    dialogs/fprop.cpp
     dragdrophelper.cpp
     enumidlist.cpp
     extracticon.cpp
     folders.cpp
     iconcache.cpp
     pidl.cpp
-    shell32_main.cpp
+    shell32.cpp
     shellitem.cpp
     shelllink.cpp
-    shellole.cpp
-    shellord.cpp
-    shellpath.cpp
-    shellreg.cpp
-    shellstring.cpp
     folders/desktop.cpp
     folders/fs.cpp
     folders/mycomp.cpp
@@ -61,22 +60,24 @@ list(APPEND SOURCE
     shlfsbind.cpp
     shlmenu.cpp
     shlview.cpp
-    shpolicy.cpp
     stubs.cpp
     systray.cpp
-    fprop.cpp
-    drive.cpp
     defcontextmenu.cpp
     openwithmenu.cpp
     newmenu.cpp
     startmenu.cpp
-    folder_options.cpp
-    filedefext.cpp
-    drvdefext.cpp
     precomp.h)
 
 add_library(shell32 SHARED
     ${SOURCE}
+    wine/control.c
+    wine/shell32_main.c
+    wine/shellole.c
+    wine/shellord.c
+    wine/shellpath.c
+    wine/shellreg.c
+    wine/shellstring.c
+    wine/shpolicy.c
     vista.c
     shell32.rc
     ${CMAKE_CURRENT_BINARY_DIR}/shell32_stubs.c