[SHELL32]
[reactos.git] / dll / win32 / shell32 / CMakeLists.txt
index 651600e..c34883d 100644 (file)
@@ -1,6 +1,7 @@
 PROJECT(SHELL)
 
 set_cpp(WITH_RUNTIME)
+spec2def(shell32.dll shell32.spec ADD_IMPORTLIB)
 
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
@@ -14,8 +15,6 @@ include_directories(
     ${REACTOS_SOURCE_DIR}/lib/atl
     ${REACTOS_SOURCE_DIR})
 
-spec2def(shell32.dll shell32.spec ADD_IMPORTLIB)
-
 list(APPEND SOURCE
     #authors.cpp
     autocomplete.cpp
@@ -23,28 +22,27 @@ list(APPEND SOURCE
     changenotify.cpp
     classes.cpp
     clipboard.cpp
-    control.cpp
     CMenuBand.cpp
     CMenuDeskBar.cpp
     dataobject.cpp
     dde.cpp
     debughlp.cpp
     desktop.cpp
-    dialogs.cpp
+    dialogs/dialogs.cpp
+    dialogs/drive.cpp
+    dialogs/drvdefext.cpp
+    dialogs/folder_options.cpp
+    dialogs/filedefext.cpp
+    dialogs/fprop.cpp
     dragdrophelper.cpp
     enumidlist.cpp
     extracticon.cpp
     folders.cpp
     iconcache.cpp
     pidl.cpp
-    shell32_main.cpp
+    shell32.cpp
     shellitem.cpp
     shelllink.cpp
-    shellole.cpp
-    shellord.cpp
-    shellpath.cpp
-    shellreg.cpp
-    shellstring.cpp
     folders/desktop.cpp
     folders/fs.cpp
     folders/mycomp.cpp
@@ -62,53 +60,32 @@ list(APPEND SOURCE
     shlfsbind.cpp
     shlmenu.cpp
     shlview.cpp
-    shpolicy.cpp
     stubs.cpp
     systray.cpp
-    fprop.cpp
-    drive.cpp
     defcontextmenu.cpp
     openwithmenu.cpp
     newmenu.cpp
     startmenu.cpp
-    folder_options.cpp
-    filedefext.cpp
-    drvdefext.cpp
     precomp.h)
 
 add_library(shell32 SHARED
     ${SOURCE}
+    wine/control.c
+    wine/shell32_main.c
+    wine/shellole.c
+    wine/shellord.c
+    wine/shellpath.c
+    wine/shellreg.c
+    wine/shellstring.c
+    wine/shpolicy.c
     vista.c
     shell32.rc
     ${CMAKE_CURRENT_BINARY_DIR}/shell32_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/shell32.def)
 
 set_module_type(shell32 win32dll UNICODE HOTPATCHABLE)
-
-target_link_libraries(shell32
-    atlnew
-    wine
-    uuid
-    recyclebin)
-
+target_link_libraries(shell32 atlnew wine uuid recyclebin)
 add_delay_importlibs(shell32 ole32 version fmifs)
-
-add_importlibs(shell32
-    advapi32
-    browseui
-    gdi32
-    user32
-    comctl32
-    comdlg32
-    shdocvw
-    shlwapi
-    devmgr
-    winspool
-    winmm
-    msvcrt
-    kernel32
-    ntdll)
-
-add_dependencies(shell32 shdocvw_v1)
+add_importlibs(shell32 advapi32 browseui gdi32 user32 powrprof comctl32 comdlg32 shdocvw shlwapi devmgr winspool winmm msvcrt kernel32 ntdll)
 add_pch(shell32 precomp.h SOURCE)
 add_cd_file(TARGET shell32 DESTINATION reactos/system32 FOR all)