[SHELL32] Use the same definitions for shell32 and it's static libs
[reactos.git] / dll / win32 / shell32 / shelldesktop / CMakeLists.txt
index b1eb11f..df1fc73 100644 (file)
@@ -1,7 +1,12 @@
-
 project(SHELL)
+
 set_cpp(WITH_RUNTIME)
-add_definitions(-DUNICODE -D_UNICODE)
+
+add_definitions(
+    -DUNICODE
+    -D_UNICODE
+    -D_ATL_NO_EXCEPTIONS)
+
 include_directories(${REACTOS_SOURCE_DIR}/sdk/lib/atl)
 
 list(APPEND SOURCE