[CMAKE] Introduce the atl_classes interface library
[reactos.git] / dll / win32 / shell32 / shellmenu / CMakeLists.txt
index 94c04fc..01b813a 100644 (file)
@@ -2,10 +2,7 @@ project(SHELL)
 
 add_definitions(
     -DUNICODE
-    -D_UNICODE
-    -D_ATL_NO_EXCEPTIONS)
-
-include_directories(${REACTOS_SOURCE_DIR}/sdk/lib/atl)
+    -D_UNICODE)
 
 list(APPEND SOURCE
     CMenuBand.cpp
@@ -16,5 +13,6 @@ list(APPEND SOURCE
     CMergedFolder.cpp
     CStartMenu.cpp)
 
-add_library(shellmenu ${SOURCE})
+add_library(shellmenu OBJECT ${SOURCE})
+target_link_libraries(shellmenu PRIVATE atl_classes)
 add_dependencies(shellmenu xdk psdk)