* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / dll / win32 / shlwapi / CMakeLists.txt
index f760833..8cb79d8 100644 (file)
@@ -20,13 +20,18 @@ list(APPEND SOURCE
     string.c
     thread.c
     url.c
+    precomp.h)
+
+add_library(shlwapi SHARED
+    ${SOURCE}
+    shlwapi.rc
     wsprintf.c
     ${CMAKE_CURRENT_BINARY_DIR}/shlwapi_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/shlwapi.def)
 
-add_library(shlwapi SHARED ${SOURCE} shlwapi.rc)
 set_module_type(shlwapi win32dll)
 target_link_libraries(shlwapi uuid wine)
 add_delay_importlibs(shlwapi userenv oleaut32 ole32 comdlg32 mpr mlang urlmon shell32 winmm version)
 add_importlibs(shlwapi user32 gdi32 advapi32 wininet msvcrt kernel32 ntdll)
+add_pch(shlwapi precomp.h SOURCE)
 add_cd_file(TARGET shlwapi DESTINATION reactos/system32 FOR all)