* Sync up to trunk head (r64921).
[reactos.git] / dll / win32 / stdole2.tlb / CMakeLists.txt
index 2abd2eb..ce7f9c2 100644 (file)
@@ -1,21 +1,15 @@
 
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
 add_typelib(std_ole_v2.idl)
-
-set_rc_compiler()
 spec2def(stdole2.tlb stdole2.tlb.spec)
 
 list(APPEND SOURCE
     rsrc.rc
     ${CMAKE_CURRENT_BINARY_DIR}/stdole2.def)
-    
-set_source_files_properties(rsrc.rc PROPERTIES OBJECT_DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/std_ole_v2.tlb)
 
+set_source_files_properties(rsrc.rc PROPERTIES OBJECT_DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/std_ole_v2.tlb)
 add_library(stdole2.tlb SHARED ${SOURCE})
-
 set_module_type(stdole2.tlb module)
 set_target_properties(stdole2.tlb PROPERTIES SUFFIX "")
-
 add_cd_file(TARGET stdole2.tlb DESTINATION reactos/system32 FOR all)