* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / dll / win32 / sti / CMakeLists.txt
index fab24cc..6d7375c 100644 (file)
@@ -7,18 +7,23 @@ add_definitions(
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 spec2def(sti.dll sti.spec)
+add_rpcproxy_files(sti_wia.idl)
 
 list(APPEND SOURCE
     sti.c
     sti_main.c
-    guid.c
+    precomp.h
     ${CMAKE_CURRENT_BINARY_DIR}/proxy.dlldata.c
-    ${CMAKE_CURRENT_BINARY_DIR}/sti_wia_p.c
+    ${CMAKE_CURRENT_BINARY_DIR}/sti_wia_p.c)
+
+add_library(sti SHARED
+    ${SOURCE}
+    guid.c
+    sti.rc
     ${CMAKE_CURRENT_BINARY_DIR}/sti.def)
 
-add_rpcproxy_files(sti_wia.idl)
-add_library(sti SHARED ${SOURCE} sti.rc)
 set_module_type(sti win32dll)
 target_link_libraries(sti wine uuid ${PSEH_LIB})
 add_importlibs(sti ole32 oleaut32 rpcrt4 advapi32 msvcrt kernel32 ntdll)
+add_pch(sti precomp.h SOURCE)
 add_cd_file(TARGET sti DESTINATION reactos/system32 FOR all)