[CMAKE]
[reactos.git] / dll / win32 / sti / CMakeLists.txt
index dd7e8e7..88ff61b 100644 (file)
@@ -10,22 +10,25 @@ add_definitions(
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(sti ${CMAKE_CURRENT_SOURCE_DIR}/sti.spec ${CMAKE_CURRENT_BINARY_DIR}/sti.def)
+spec2def(sti.dll sti.spec)
 
-add_library(sti SHARED
+list(APPEND SOURCE
     regsvr.c
     sti.c
     sti_main.c
-    sti_wia.idl)
+    ${CMAKE_CURRENT_BINARY_DIR}/sti.def)
+
+add_rpcproxy_library(stiproxy sti_wia.idl)
+
+add_library(sti SHARED ${SOURCE})
 
 set_entrypoint(sti 0)
 
 target_link_libraries(sti
-    ${CMAKE_CURRENT_BINARY_DIR}/sti.def
-    sti_proxy
+    stiproxy
     wine
     uuid
-    pseh)
+    ${PSEH_LIB})
 
 add_importlibs(sti
     ole32
@@ -35,7 +38,4 @@ add_importlibs(sti
     kernel32
     ntdll)
 
-add_dependencies(sti sti_def)
-
-rpcproxy(sti sti_wia.idl)
-add_cab_target(sti 1)
+add_cd_file(TARGET sti DESTINATION reactos/system32)