[CMAKE]
[reactos.git] / dll / win32 / sti / CMakeLists.txt
index e0b7a47..f069fbf 100644 (file)
@@ -10,22 +10,24 @@ add_definitions(
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(sti ${CMAKE_CURRENT_SOURCE_DIR}/sti.spec ${CMAKE_CURRENT_BINARY_DIR}/sti.def)
+spec2def(sti.dll sti.spec)
 
-add_library(sti SHARED
+list(APPEND SOURCE
     regsvr.c
     sti.c
     sti_main.c
-    sti_wia.idl)
+    ${CMAKE_CURRENT_BINARY_DIR}/sti.def)
+
+rpcproxy(sti sti_wia.idl)
+
+add_library(sti SHARED ${SOURCE})
 
 set_entrypoint(sti 0)
 
 target_link_libraries(sti
-    ${CMAKE_CURRENT_BINARY_DIR}/sti.def
-    sti_proxy
     wine
     uuid
-    pseh)
+    ${PSEH_LIB})
 
 add_importlibs(sti
     ole32
@@ -35,7 +37,4 @@ add_importlibs(sti
     kernel32
     ntdll)
 
-add_dependencies(sti sti_def)
-
-rpcproxy(sti sti_wia.idl)
-add_livecd_target(sti reactos/system32)
+add_cab_target(sti 1)