* Sync up to trunk HEAD (r62286).
[reactos.git] / dll / win32 / sxs / CMakeLists.txt
index b21b2dd..97f80b3 100644 (file)
@@ -7,12 +7,16 @@ list(APPEND SOURCE
     cache.c
     name.c
     sxs.c
+    sxs_private.h
+    ${CMAKE_CURRENT_BINARY_DIR}/sxs_stubs.c)
+
+add_library(sxs SHARED
+    ${SOURCE}
     guid.c
-    ${CMAKE_CURRENT_BINARY_DIR}/sxs_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/sxs.def)
 
-add_library(sxs SHARED ${SOURCE})
 set_module_type(sxs win32dll)
 target_link_libraries(sxs wine)
 add_importlibs(sxs oleaut32 ole32 msvcrt kernel32 ntdll)
+add_pch(sxs sxs_private.h SOURCE)
 add_cd_file(TARGET sxs DESTINATION reactos/system32 FOR all)