[CMAKE]
[reactos.git] / dll / win32 / tapi32 / CMakeLists.txt
index abb19d5..41017c2 100644 (file)
@@ -4,18 +4,21 @@ add_definitions(-D__WINESRC__)
 
 spec2def(tapi32.dll tapi32.spec)
 
-add_library(tapi32 SHARED
+list(APPEND SOURCE
     assisted.c
     internal.c
     line.c
     phone.c
+    ${CMAKE_CURRENT_BINARY_DIR}/tapi32_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/tapi32.def)
 
+add_library(tapi32 SHARED ${SOURCE})
+
 set_entrypoint(tapi32 0)
 
 target_link_libraries(tapi32 wine)
 
 add_importlibs(tapi32 advapi32 kernel32 ntdll)
-add_dependencies(tapi32 psdk buildno_header)
+add_dependencies(tapi32 psdk)
 
-add_cab_target(tapi32 1)
\ No newline at end of file
+add_cd_file(TARGET tapi32 DESTINATION reactos/system32 FOR all)