* Sync up to trunk HEAD (r62286).
[reactos.git] / dll / win32 / tapi32 / CMakeLists.txt
index 5fc9bee..f474b3b 100644 (file)
@@ -8,11 +8,15 @@ list(APPEND SOURCE
     internal.c
     line.c
     phone.c
-    ${CMAKE_CURRENT_BINARY_DIR}/tapi32_stubs.c
+    precomp.h
+    ${CMAKE_CURRENT_BINARY_DIR}/tapi32_stubs.c)
+
+add_library(tapi32 SHARED
+    ${SOURCE}
     ${CMAKE_CURRENT_BINARY_DIR}/tapi32.def)
 
-add_library(tapi32 SHARED ${SOURCE})
 set_module_type(tapi32 win32dll)
 target_link_libraries(tapi32 wine)
 add_importlibs(tapi32 advapi32 msvcrt kernel32 ntdll)
+add_pch(tapi32 precomp.h SOURCE)
 add_cd_file(TARGET tapi32 DESTINATION reactos/system32 FOR all)