[CMAKE]
[reactos.git] / dll / win32 / ufatx / CMakeLists.txt
index b6c32fe..c4914b6 100644 (file)
@@ -1,14 +1,13 @@
 
-spec2def(ufatx ${CMAKE_CURRENT_SOURCE_DIR}/ufatx.spec ${CMAKE_CURRENT_BINARY_DIR}/ufatx.def)
+spec2def(ufatx.dll ufatx.spec)
 
-add_library(ufatx SHARED ufatx.rc)
+add_library(ufatx SHARED ufatx.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/ufatx.def)
 
 set_entrypoint(ufatx 0)
 
-target_link_libraries(ufatx
-    ${CMAKE_CURRENT_BINARY_DIR}/ufatx.def
-    vfatxlib)
+target_link_libraries(ufatx vfatxlib)
 
 add_importlibs(ufatx gcc kernel32 ntdll)
-add_dependencies(ufatx ufatx_def psdk buildno_header)
-add_livecd_target(ufatx reactos/system32)
\ No newline at end of file
+add_dependencies(ufatx psdk buildno_header)
+add_cab_target(ufatx 1)
\ No newline at end of file