[CMAKE]
[reactos.git] / dll / win32 / untfs / CMakeLists.txt
index 26f8dc9..0416542 100644 (file)
@@ -1,14 +1,14 @@
 
-spec2def(untfs ${CMAKE_CURRENT_SOURCE_DIR}/untfs.spec ${CMAKE_CURRENT_BINARY_DIR}/untfs.def)
+spec2def(untfs.dll untfs.spec)
 
-add_library(untfs SHARED untfs.c untfs.rc)
+list(APPEND SOURCE
+    untfs.c
+    untfs.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/untfs.def)
 
-set_module_type(untfs win32dll)
-
-target_link_libraries(untfs
-    ${CMAKE_CURRENT_BINARY_DIR}/untfs.def
-    ntfslib)
+add_library(untfs SHARED ${SOURCE})
 
-add_importlibs(untfs kernel32 ntdll)
-add_dependencies(untfs untfs_def)
-add_livecd_target(untfs reactos/system32)
+set_module_type(untfs win32dll)
+target_link_libraries(untfs ntfslib)
+add_importlibs(untfs msvcrt kernel32 ntdll)
+add_cd_file(TARGET untfs DESTINATION reactos/system32 FOR all)