* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / dll / win32 / urlmon / CMakeLists.txt
index 81404de..8ced4f8 100644 (file)
@@ -7,9 +7,6 @@ add_definitions(
     -DWINE_REGISTER_DLL
     -DPROXY_CLSID_IS="{0x79EAC9F1,0xBAF9,0x11CE,{0x8C,0x82,0x00,0xAA,0x00,0x4B,0xA9,0x0B}}")
 
-#remove_definitions(-D_WIN32_WINNT=0x502)
-#add_definitions(-D_WIN32_WINNT=0x600)
-
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 spec2def(urlmon.dll urlmon.spec ADD_IMPORTLIB)
 add_rpcproxy_files(urlmon_urlmon.idl)
@@ -36,14 +33,18 @@ list(APPEND SOURCE
     uri.c
     urlmon_main.c
     usrmarshal.c
+    urlmon_main.h)
+
+add_library(urlmon SHARED
+    ${SOURCE}
+    urlmon.rc
     ${CMAKE_CURRENT_BINARY_DIR}/proxy.dlldata.c
     ${CMAKE_CURRENT_BINARY_DIR}/urlmon_urlmon_p.c
     ${CMAKE_CURRENT_BINARY_DIR}/urlmon_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/urlmon.def)
 
-add_library(urlmon SHARED ${SOURCE} urlmon.rc)
 set_module_type(urlmon win32dll)
 target_link_libraries(urlmon uuid wine ${PSEH_LIB})
 add_importlibs(urlmon rpcrt4 propsys ole32 oleaut32 shlwapi shell32 wininet user32 advapi32 advpack msvcrt kernel32 ntdll)
-add_pch(urlmon urlmon_main.h)
+add_pch(urlmon urlmon_main.h SOURCE)
 add_cd_file(TARGET urlmon DESTINATION reactos/system32 FOR all)